Cloud Docs Home > F5 OpenStack Solutions Index

Releases and Versioning

See also

Please see the Partners page for information about our OpenStack distribution platform partnerships and certifications.

Documentation

This documentation release, version 1.0, corresponds to the following version(s) of each F5 OpenStack Integration component.

Docs and Component Versioning
Component Version
f5-openstack-agent 8.x, 9.x, 10.x
f5-openstack-heat 7.x, 8.x, 9.x, 10.x
f5-openstack-heat-plugins 7.x, 8.x, 9.x, 10.x
f5-openstack-lbaasv2-driver 8.x, 9.x, 10.x
f5-openstack-lbaasv1 [1] 7.x, 8.x, 9.x

Footnotes

[1]F5 ceased to repair defects and perform maintenance on the F5 OpenStack LBaaS version 1 integration as of the Openstack Ocata release (April 2017). See the Neutron LBaaSv1 section below for more information.

F5 OpenStack Heat Integration

OpenStack & F5 BIG-IP compatibility
F5 Heat templates F5 Heat plugins OpenStack version BIG-IP version(s)
7.x 7.x Kilo

11.5.2+

11.6.x

8.x 8.x Liberty

11.5.2+

11.6.x

12.1.x

13.0.x

9.x 9.x Mitaka

11.5.2+

11.6.x

12.1.x

13.0.x

10.x 10.x Newton

11.5.2+

11.6.x

12.1.x

13.0.x

F5 OpenStack LBaaS Connector

Neutron LBaaSv2

OpenStack LBaaSv2 & F5 BIG-IP compatibility
F5 LBaaS Connector version(s) OpenStack version BIG-IP version(s)
8.x Liberty

11.5.2+

11.6.x

12.1.x

13.0.x

9.x Mitaka

11.5.2+

11.6.x

12.1.x

13.0.x

10.x Newton

11.5.2+

11.6.x

12.1.x

13.0.x

Linux OS Compatibility
F5 LBaaS Connector version(s) RHEL version(s) Ubuntu version(s)
8.x, 9.x, 10.x 6, 7 12, 14

Neutron LBaaSv1

Important

End of Technical Support for F5 OpenStack LBaaS version 1

The F5 OpenStack LBaaS version 1 integration reached End of Technical Support (EOTS) effective with the Openstack Ocata release in April 2017.

This announcement is in compliance with the OpenStack community deprecation of the OpenStack Neutron LBaaS version 1 plugin. F5 encourages customers to move to OpenStack LBaaS version 2.

For additional information, please refer to the F5 End of Life policy.

The table below is for informational purposes only.

OpenStack LBaaSv1 & F5 BIG-IP compatibility
F5 LBaaSv1 Connector version(s) OpenStack version BIG-IP version(s)
7.x Kilo 11.5.2+, 11.6.x, 12.0.x
8.x Liberty 11.5.2+, 11.6.x, 12.0.x
9.x Mitaka 11.5.2+, 11.6.x, 12.0.x